Welcome to the Ad-Free KIA Telluride Community!

Please register with the BIGGEST and busiest Telluride community online. We'd LOVE to have you! Please note: This is an ADVERTISEMENT FREE community! No advertising is permitted. None.

Register Log in
  • PLEASE NOTE: This is a private community with only a few publicly accessible areas. Please sign up for open access to full level content.

AC Leak. AC Issues

Fonzie

New member
Messages
3
Reaction score
1
Points
3
I want to start off by saying my wife and I really like this SUV. We waited and did our research before we bought the Telluride S model. Well, we have 400 miles on it and the AC started blowing hot air and gray smoke came out from under the engine and it smelled like Freon. Well its been at the KIA dealership all day and they got back to me saying there is a leak in the AC and have to wait for the KIA engineers to get back to them. It's new and we understood there might be some issues but this sucks. We only had it for 7 days. My question to you is: Have any of you had issues with the AC? Thank you in advance I will keep you up to date.
 

Tim-in-CA

FOUNDING MEMBER
Messages
240
Reaction score
157
Points
43
Location
Sunny So Cal
Sorry to hear … mine has been working OK, but haven't used AC too much. Let us know what Kia finds. These sort of issues are common with new vehicles. I'm sure I'll experience a bugaboo soon enuf!
 

ATL3630

FOUNDING MEMBER
Messages
110
Reaction score
70
Points
28
I’ve used mine quite a lot since i live in the South. No issues so far. Sorry to hear about your problem but I’m sure Kia will get it corrected.
 

plutoridge

FOUNDING MEMBER
Messages
13
Reaction score
5
Points
3
Sorry to hear about this and thank you for posting. Please do keep us posted with your updates. It'd be interesting to see how Kia handles these initial issues.
 

Fonzie

New member
Messages
3
Reaction score
1
Points
3
The KIA Dealership figured out the problem. The AC line was not installed correctly under the car. The AC leaked because of the grove in the line. The bolts holding the line were bent. Pictures attached.
 

Attachments

EROCK

Member
Messages
35
Reaction score
22
Points
8
Location
Orange County, CA
The KIA Dealership figured out the problem. The AC line was not installed correctly under the car. The AC leaked because of the grove in the line. The bolts holding the line were bent. Pictures attached.
Aw man whatta bummer! Glad that found that though! That’s an easy thing to miss under there!
 

Kirkster

FOUNDING MEMBER
Messages
36
Reaction score
17
Points
8
The KIA Dealership figured out the problem. The AC line was not installed correctly under the car. The AC leaked because of the grove in the line. The bolts holding the line were bent. Pictures attached.
Proudly built in Georgia...:)
 

Buckeye-TRide

Member
Messages
88
Reaction score
33
Points
18
There’s a reason they say not to buy a first gen of any new vehicle and it’s due to stuff like this. That’s the price we pay to have the latest and greatest. Glad they got it worked out and thanks for the update in case anyone else has this issue.
 

Fonzie

New member
Messages
3
Reaction score
1
Points
3
There’s a reason they say not to buy a first gen of any new vehicle and it’s due to stuff like this. That’s the price we pay to have the latest and greatest. Glad they got it worked out and thanks for the update in case anyone else has this issue.
You hit the nail on the head. I asked the service department if this is an issue they are having. I was told the only thing they have come across is updating the ECU software. The AC line is the first here in Tucson, AZ and was most likely caused by a faulty install. He said those lines are hand installed. The AC line is on back order and will be in next week. This stinks.... Bought it last Monday 4/29 and have only driven it 5 days.... But hey it is what it is and its not a serious issue.
 
Your email address will not be publicly visible. We will only use it to contact you to confirm your post.
Top