No soliciting permitted.

Battery discharge warning

Jack Griffin

New member
Messages
10
Reaction score
12
Points
3
For the second time in a month our SX prestige model would not crank giving a battery discharge warning on the center screen. of course if you can jump it off it isn't the battery dying if something else draining the battery. Anyone else had this issue?
 

freddyvince

FOUNDING MEMBER
Messages
21
Reaction score
15
Points
3
I got this problem too, impossible to open the door and start the car. The problem: the positive pole on the battery was loose...a 30 seconds repair. And now, everything was fine.
 

jazzyone

FOUNDING MEMBER
Messages
681
Reaction score
388
Points
63
For the second time in a month our SX prestige model would not crank giving a battery discharge warning on the center screen. of course if you can jump it off it isn't the battery dying if something else draining the battery. Anyone else had this issue?

You know the UVO is always on and connected to LTE? Probably low power mode but still draining the battery. That’s how the features of UVO work.

With these connected cars, you’ll have to drive it regularly or plug it into a trickle charger.
 

Jack Griffin

New member
Messages
10
Reaction score
12
Points
3
You know the UVO is always on and connected to LTE? Probably low power mode but still draining the battery. That’s how the features of UVO work.

With these connected cars, you’ll have to drive it regularly or plug it into a trickle charger.

We drive it almost everyday. 20 miles each way to work. Sunday was the only day it hadn't moved in the last 14 days. But the battery issue was this morning, and we drove it yesterday to work without issue.
______________________________
 

Jack Griffin

New member
Messages
10
Reaction score
12
Points
3
I got this problem too, impossible to open the door and start the car. The problem: the positive pole on the battery was loose...a 30 seconds repair. And now, everything was fine.
I will double check the battery cable for any issue, but since I jumped it off this morning, I didn't notice it being loose at the time. Just glad I'm not the only one having the issue so far. I learned 2 weeks ago this car will drive itself in cruise control mode. Will turn the wheel for you too. At least on my SX Prestige.
 
Looking to cover or replace the KIA emblems on your Telluride? Look no further than right here in our own forum store - where orders are shipped immediately!

Buzmin

New member
Messages
19
Reaction score
3
Points
3
When the VW Atlas was first introduced they had a lot of battery problems, mine was one of them, they finally did acknowledge the problem and replaced a lot of battery's
 

jazzyone

FOUNDING MEMBER
Messages
681
Reaction score
388
Points
63
We drive it almost everyday. 20 miles each way to work. Sunday was the only day it hadn't moved in the last 14 days. But the battery issue was this morning, and we drove it yesterday to work without issue.

In that case there are 3 possibilities. 1) you left something on, 2) the charging system isn’t working correctly, 3) your battery is defective.

The KT has a AGM battery. AGM batteries need to be above 50% charge for longevity. Perhaps it was stored below 50% for a long time.

I would take it to the dealer, I think a least one person reported that they had to replace the battery.
______________________________
 

Jack Griffin

New member
Messages
10
Reaction score
12
Points
3
In that case there are 3 possibilities. 1) you left something on, 2) the charging system isn’t working correctly, 3) your battery is defective.

The KT has a AGM battery. AGM batteries need to be above 50% charge for longevity. Perhaps it was stored below 50% for a long time.

I would take it to the dealer, I think a least one person reported that they had to replace the battery.

Going to drop it off tonight for them to check to see which one. Last time this happened, the sent someone out to jump it off and just assumed the headlights were left on, but based on a timer these normally cut themselves off, so it's hard to believe it was just that. This time nothing was left on or plugged in.
 

hammick

Active member
Messages
203
Reaction score
90
Points
28
Assuming there isn't a loose battery cable insist that they replace that battery under warranty. Once a lead acid battery is depleted permanent damage is done. Charging it back up won't reverse the damage. There may be a way to reverse the damage using a trickle charge with a desulphation mode but that could take a month and with a daily driver isn't feasible. Sometimes new batteries just have a defect and live a short life or the dealer let the battery discharge. An example would be a car in the showroom that has it's interior lights on a good part of the day.
 

hammick

Active member
Messages
203
Reaction score
90
Points
28
In that case there are 3 possibilities. 1) you left something on, 2) the charging system isn’t working correctly, 3) your battery is defective.

The KT has a AGM battery. AGM batteries need to be above 50% charge for longevity. Perhaps it was stored below 50% for a long time.

I would take it to the dealer, I think a least one person reported that they had to replace the battery.

AGM batteries are still lead acid batteries. They need to be at 100% SOC (state of charge) for longevity. Even with a daily driver I suggest putting a tender on the vehicle overnight at least once a month. A $50 battery tender will pay for itself many times over. A new battery every 3 -5 years vs. 8 - 10 years. Plus you can use it on your tractor, MC, generator, etc.
 
G

G-83824

Assuming there isn't a loose battery cable insist that they replace that battery under warranty. Once a lead acid battery is depleted permanent damage is done. Charging it back up won't reverse the damage. There may be a way to reverse the damage using a trickle charge with a desulphation mode but that could take a month and with a daily driver isn't feasible. Sometimes new batteries just have a defect and live a short life or the dealer let the battery discharge. An example would be a car in the showroom that has it's interior lights on a good part of the day.
They did replace the battery under warranty and since it was the 2nd time they checked the electrical outputs to be sure it was just the battery.
______________________________
 

Alohatl

Member
Messages
36
Reaction score
11
Points
8
I wonder if the Telluride has some sort of battery health monitoring or need to connect to a OBD2 access port?
 

Tim-in-CA

FOUNDING MEMBER
Messages
649
Reaction score
453
Points
63
Location
Sunny So Cal
AGM batteries are still lead acid batteries. They need to be at 100% SOC (state of charge) for longevity. Even with a daily driver I suggest putting a tender on the vehicle overnight at least once a month. A $50 battery tender will pay for itself many times over. A new battery every 3 -5 years vs. 8 - 10 years. Plus you can use it on your tractor, MC, generator, etc.

i keep all my vehicles on battery tenders. Batteries will last much longer if maintained. But I think the OP’s battery is defective. Dealer should test it.
 
G

G-253705

For the second time in a month our SX prestige model would not crank giving a battery discharge warning on the center screen. of course if you can jump it off it isn't the battery dying if something else draining the battery. Anyone else had this issue?
For the second time in a month our SX prestige model would not crank giving a battery discharge warning on the center screen. of course if you can jump it off it isn't the battery dying if something else draining the battery. Anyone else had this issue?
I have the same issue and dealer order new battery
 

Ciscokd2000

Active member
Messages
125
Reaction score
51
Points
28
I will double check the battery cable for any issue, but since I jumped it off this morning, I didn't notice it being loose at the time. Just glad I'm not the only one having the issue so far. I learned 2 weeks ago this car will drive itself in cruise control mode. Will turn the wheel for you too. At least on my SX Prestige.
Hello everyone, I had the same issue , had the Kia jump started three times. I finally took
it to the dealer . The battery had a bad cell. They replaced the battery , no more issues.
______________________________
 

Ciscokd2000

Active member
Messages
125
Reaction score
51
Points
28
For the second time in a month our SX prestige model would not crank giving a battery discharge warning on the center screen. of course if you can jump it off it isn't the battery dying if something else draining the battery. Anyone else had this issue?
See my post won't start
 
G

G-534270

For the second time in a month our SX prestige model would not crank giving a battery discharge warning on the center screen. of course if you can jump it off it isn't the battery dying if something else draining the battery. Anyone else had this issue?
Yes same i have
Already replace one battery and next week same issue
 

kimmyrenee48

New member
Messages
1
Reaction score
0
Points
1
This will be my 2nd time with the telluride battery dying....I could have been stranded somewhere since I don't have a portable battery charger....where do you get one?
 
Top