Welcome to the Ad-Free KIA Telluride Community!

Please register with the BIGGEST and busiest Telluride community online. We'd LOVE to have you! Please note: This is an ADVERTISEMENT FREE community! No advertising is permitted. None.

Register Log in

Hello from Black Copper SX Prestige in MN

Rachelrenae

New member
Messages
6
Reaction score
0
Points
1
Hi there! I found you all because I'm having a problem with my speedometer not working. Hopefully I'll get some insight, but either way I'm glad I found the forum! It's nice to meet other Telluride owners.
 

mrmac

FOUNDING MEMBER
Messages
484
Reaction score
335
Points
63
Location
El paso Texas
Hi there! I found you all because I'm having a problem with my speedometer not working. Hopefully I'll get some insight, but either way I'm glad I found the forum! It's nice to meet other Telluride owners.
Welcome. Please describe what you mean by the speedometer not working.
 
Looking to cover or replace the KIA emblems on your Telluride? Look no further than right here in our own forum store - where orders are shipped immediately!

Rachelrenae

New member
Messages
6
Reaction score
0
Points
1
I was driving down the road and the speedometer was at 0. My heads up display also was reading 0, and when I switched to the electronic speedometer, it too, read 0. I was able to go on to Google Maps and track my speed that way and then set my cruise, but then I had to pass someone so I pressed the gas to do that and the car kept getting faster even when I took my foot off the gas so I hit the break and of course the cruise disengaged. After that I couldn't get the cruise to work again, either. I posted in a forum about it because it happened to one other person, but that person said their speedometer worked after leaving the car parked for 30 minutes or so. Then they were going to talk to the dealer but there isn't an update.
 

Rachelrenae

New member
Messages
6
Reaction score
0
Points
1
I was driving down the road and the speedometer was at 0. My heads up display also was reading 0, and when I switched to the electronic speedometer, it too, read 0. I was able to go on to Google Maps and track my speed that way and then set my cruise, but then I had to pass someone so I pressed the gas to do that and the car kept getting faster even when I took my foot off the gas so I hit the break and of course the cruise disengaged. After that I couldn't get the cruise to work again, either. I posted in a forum about it because it happened to one other person, but that person said their speedometer worked after leaving the car parked for 30 minutes or so. Then they were going to talk to the dealer but there isn't an update.
And when the cruise was working it was reading 20 on the heads up. Just another tidbit.
 

Mr.JB

FOUNDING MEMBER
Messages
110
Reaction score
78
Points
28
Location
Minnesota
I wonder if it needed to reset itself and a power off enabled it. It would be tough to take it to a dealership if it back operational and diagnose the problem.

Oh and hello. I also am in Minnesota with. a black copper SXP. Our has Dune Brown interior. Located in the north Metro, where are you located??
 

Rachelrenae

New member
Messages
6
Reaction score
0
Points
1
I wonder if it needed to reset itself and a power off enabled it. It would be tough to take it to a dealership if it back operational and diagnose the problem.

Oh and hello. I also am in Minnesota with. a black copper SXP. Our has Dune Brown interior. Located in the north Metro, where are you located??
I wonder, too. I did stop and restart it, but I didn't wait very long as I was in someone's driveway. I was thinking the same thing with the dealership. The closest one is an hour and a half or more away anyway so I'm not going until I need to. They are going to come pick it up and get me a loaner at some point because when it came in it had an issue with one of the middle row bucket seats, just a part that came loose, so no biggy, but I'm waiting until the remote start becomes available to get it all done at once.

I'm in Bemidji. We have the black interior in ours. I liked the look of both, but we have young children. Enough said. ;-) I love the Black Copper more every single time I see it!

Thank you for your input!
 
Top