No soliciting permitted.

LCD instrument cluster black

JenniferLB1108

New member
Messages
7
Reaction score
3
Points
3
Has anyone experienced a completely black and blank LCD instrument cluster next to the odometer? I just bought my car on Saturday and it is the 2022 and every time I turn on the car now the instrument cluster LCD monitor fails to come on. Even when I click on the menu button from the steering wheel, nothing happens. Yesterday, I was able to turn the car off and turn it back on to reset, but now it doesn’t matter what I do, it still doesn’t show up. I have a service appointment tomorrow, but I’m just curious if this is something anyone else has experienced and what the issue ended up being.
 

Splitxc

New member
Messages
10
Reaction score
6
Points
3
You guys need to keep filing complaints on NHTSA so that this issue would get more attention and see how many are affected. I'm not seeing this issue yet on my 21 LX with almost 2k mi. /knocks on wood
Just filed. Would it help if we have bad reviews too until resolved?
 

LSanta

New member
Messages
1
Reaction score
0
Points
1
Same issue in my Telluride 2022, EX trim. Screen turn on sometimes and some other times it just does not. Call a local dealer and they say it's and updated or something. Got my appoiment for August 14, 2021. I will let you know if my issue get fix.
 

Tellthemride

Well-known member
Messages
2,066
Reaction score
1,562
Points
113
Same issue in my Telluride 2022, EX trim. Screen turn on sometimes and some other times it just does not. Call a local dealer and they say it's and updated or something. Got my appoiment for August 14, 2021. I will let you know if my issue get fix.
That does sound plausible the cluster screen is blank because of software loaded on the head unit. I know the unit of distance (mph vs kmh) setting is controlled from the head unit in the navigation settings, and it changes for both the cluster and HUD screen when you adjust it. Would be a much easier fix to update software than to replace the cluster.
______________________________
 

jets2008

New member
Messages
8
Reaction score
3
Points
3
Location
Long Island, New York
Same issue in my Telluride 2022, EX trim. Screen turn on sometimes and some other times it just does not. Call a local dealer and they say it's and updated or something. Got my appoiment for August 14, 2021. I will let you know if my issue get fix.
Let us know what happens...I'm still waiting to hear back from my dealership.
 

Splitxc

New member
Messages
10
Reaction score
6
Points
3
I took mine in today and sure enough they "couldn't recreate the issue." I have a log and videos of every time it's happened, so they put in a case to Kia's "Tech line" whatever that means.

Update from Kia "tech line" - Kia is familiar with the issue. They have engineers working on the issue at this moment. As of now, they advised there is no fix for the issue. Technician is going to provide case #.

Yikes! So we wait...
 
Last edited:

Sevi

Member
Messages
83
Reaction score
36
Points
18
I read somewhere here that they took the cluster out, put some dialectric grease on the connections and then put the cluster back in, problem solved. If I remember correctly this was done at the dealer and is faster than waiting to have a new cluster shipped and reprogrammed.
Also, it was reported that a battery was acting up causing all these electrical gremlins but on a brand new car I would expect none of these issues.
 

rhaar

New member
Messages
6
Reaction score
3
Points
3
Yep. Bought it yesterday and this happened today. After I came out of the store it came back on. 2022 Telluride S model.
______________________________
 

rodzilla7

New member
Messages
4
Reaction score
1
Points
3
Same here. We took delivery of our 2022 Telluride EXP AWD yesterday afternoon. Everything was working normally during the test drive and post-sale walk through. Drove home 25-ish miles and the small digital cluster was blank/black on our first outing. Didn't even notice at first. Tried a few things to get the screen back up, but nothing worked.

Contacted our service department and they're having me try a couple more things. Right away, they acknowledged the issue and were concerned about us not being able to access some of the safety features. They are ready for me to schedule a service appointment, provided that the above does not remedy the issue.

I would be more "freaked out", had I not been made aware of the issue by this forum. I was hoping the issue would skip our unit, but {{shrug}}. Feeling Blessed to be in a position where this is even an issue. Confident that Kia will make it right :)
 

JTMcGIll

New member
Messages
2
Reaction score
0
Points
1
My issue is not the same as the video @Bearicus23 posted. No issue with the whole dashboard flashing or the gauges jumping.

On startup the system check video runs on the instrument LCD screen then the screen goes black. The rest of the dashboard is working normally.

Is this the fix? Need to get the LCD screen replaced? Problem is the issue is intermittent, and the dealer I purchased from is a 1.5 hour drive from my house. I will get a video next time it happens to post / show the dealer.
@Ooglesmorf300 same exact thing is happening to me. I thought I had messed up a setting. Third time in 2 weeks. Did they do anything to correct it for you?
 

walkman

New member
Messages
1
Reaction score
1
Points
3
Has anyone experienced a completely black and blank LCD instrument cluster next to the odometer? I just bought my car on Saturday and it is the 2022 and every time I turn on the car now the instrument cluster LCD monitor fails to come on. Even when I click on the menu button from the steering wheel, nothing happens. Yesterday, I was able to turn the car off and turn it back on to reset, but now it doesn’t matter what I do, it still doesn’t show up. I have a service appointment tomorrow, but I’m just curious if this is something anyone else has experienced and what the issue ended up being.
I am having the same issue on a brand new 2022 model S. Bought the car 7/10/21. First time the screen went black on 7/12, happened again today 7/17. It looks like a lot of people having the same issue so hopefully Kia addresses the problem quickly. I am planning to visit a service center next week and I will keep you posted on the fix. Please do the same. Thanks.
 

Joe Telluride

New member
Messages
3
Reaction score
0
Points
1
Same just happened to us. Bought our 2022 telluride 2 days ago and shut car off to go into restaurant. Can't back, and screen shows system check but then goes black. Had anyone resolved this?
______________________________
 
Looking to cover or replace the KIA emblems on your Telluride? Look no further than right here in our own forum store - where orders are shipped immediately!

Insgirl40

New member
Messages
2
Reaction score
4
Points
3
Same story here. Purchased 7-10 2022 Telluride #0035, Drove off the lot, 2 miles down the road, screen went out. Went back and had it reset, has been on and off since then. Spoke to my dealer yesterday and was told they had spoke to Kia engineers and they said they are finalizing the software update and will be sending soon. My dealer (Fort Bend Kia near Houston, Tx) has been very responsive.
 

Emike8179

New member
Messages
3
Reaction score
0
Points
1
Bought a 2022 S about two weeks ago. The screen has gone blank 4 times since I’ve started to drive it. I have an appointment this coming Friday. The service guy said he has not heard of the issue. I told him it’s all over the forums. I hope the problem is recreated when I drive it there. I will let you all know what happens.
 

Attachments

  • 05EE7E79-70E0-4AFD-A539-55114C15FF29.jpeg
    05EE7E79-70E0-4AFD-A539-55114C15FF29.jpeg
    149.2 KB · Views: 10
Last edited:

clauer

New member
Messages
1
Reaction score
0
Points
1
Same thing here. Got our brand new 2022 S 4 days ago and it has happened on and off about 6 or 7 times now. Shows system check screen, then goes completely black. We called our dealer and have to make an appointment. They seemed unfamiliar with the issue.
 
G

G-78911

Has anyone experienced a completely black and blank LCD instrument cluster next to the odometer? I just bought my car on Saturday and it is the 2022 and every time I turn on the car now the instrument cluster LCD monitor fails to come on. Even when I click on the menu button from the steering wheel, nothing happens. Yesterday, I was able to turn the car off and turn it back on to reset, but now it doesn’t matter what I do, it still doesn’t show up. I have a service appointment tomorrow, but I’m just curious if this is something anyone else has experienced and what the issue ended up being.
Same thing with our 2022 ex, bought it a week ago
______________________________
 
G

G-708612

Bought 2022 EX Premium package with Tow AWD on Saturday 7/17/21 this issue happened to me today 7/20/21 twice. Both times is when I traveled five miles from the house. Does it have something to do with that short distance traveled.
 

Joe Telluride

New member
Messages
3
Reaction score
0
Points
1
Same issue in my Telluride 2022, EX trim. Screen turn on sometimes and some other times it just does not. Call a local dealer and they say it's and updated or something. Got my appoiment for August 14, 2021. I will let you know if my issue get fix.
We took ours in and they couldn't find or know what this was happening. That same day the dashboard LCD went out again. Later today back on. Very frustrating, especially in this price point, and potential safety hazards of not knowing what settings you may have selected.
 

Joe Telluride

New member
Messages
3
Reaction score
0
Points
1
Happened to ours. Picked up on Friday and it goes blank after "system check" just about every other time the vehicle is driven.
Same. Brought to dealer and they couldn't find a solve. Went off again and now back on.
 

rodzilla7

New member
Messages
4
Reaction score
1
Points
3
Same here. We took delivery of our 2022 Telluride EXP AWD yesterday afternoon. Everything was working normally during the test drive and post-sale walk through. Drove home 25-ish miles and the small digital cluster was blank/black on our first outing. Didn't even notice at first. Tried a few things to get the screen back up, but nothing worked.

Contacted our service department and they're having me try a couple more things. Right away, they acknowledged the issue and were concerned about us not being able to access some of the safety features. They are ready for me to schedule a service appointment, provided that the above does not remedy the issue.

I would be more "freaked out", had I not been made aware of the issue by this forum. I was hoping the issue would skip our unit, but {{shrug}}. Feeling Blessed to be in a position where this is even an issue. Confident that Kia will make it right :)
Our instrument cluster turned “ON” again the following day, then “OFF” the day after. Reached out to our tech again.

He informed us that Kia is aware of the issue and is working on a software solution. He didn’t give a timeframe and also didn’t think we would need to bring the vehicle to service as the update should be downloadable (when available).
 
nightfall your telluride
Get your luxury badges right here in the Telluride forum store
Kia Telluride Clubs
Protect your vehicle from code scanners


Top