Welcome to the Ad-Free KIA Telluride Community!

Please register with the BIGGEST and busiest Telluride community online. We'd LOVE to have you! Please note: This is an ADVERTISEMENT FREE community! No advertising is permitted. None.

Register Log in

Telluride no A/C

Cjohnston

New member
Messages
5
Reaction score
4
Points
3
Well I've had my Telluride about four months and it's back in the shop for the second time. First to replace faulty gaskets in the differential and now the A/C doesn't work. It will blow cold for 15 minutes and then blow hot. I was told it's most likely a faulty compressor.
 
Looking to cover or replace the KIA emblems on your Telluride? Look no further than right here in our own forum store - where orders are shipped immediately!

ernysan

Active member
Messages
189
Reaction score
96
Points
28
Please keep the post until they solve your issue and let us know the details thanks for share and hope you get your ride SOONNNN
 

Cjohnston

New member
Messages
5
Reaction score
4
Points
3
Well I've had my Telluride about four months and it's back in the shop for the second time. First to replace faulty gaskets in the differential and now the A/C doesn't work. It will blow cold for 15 minutes and then blow hot. I was told it's most likely a faulty compressor.
Update: Apparently the system was overfilled with freon. This caused the system to shut down and the compressor to freeze up. The system was "evaced" and refilled to the correct level. As of now it is cooling properly.
 

Cjohnston

New member
Messages
5
Reaction score
4
Points
3
Update: Apparently the system was overfilled with freon. This caused the system to shut down and the compressor to freeze up. The system was "evaced" and refilled to the correct level. As of now it is cooling properly.
Second update: It's back in the shop and they don't know what the heck is wrong with the A/C.
 

Cjohnston

New member
Messages
5
Reaction score
4
Points
3
Second update: It's back in the shop and they don't know what the heck is wrong with the A/C.
Third update: I was told it has a bad compressor, which is what was suspected originally. Of course parts have to be ordered. So, faulty gaskets on the differential and a bad a/c compressor, but who's counting. I never had a problem with my KIA Borrego.
 
Top