No soliciting permitted.

Retrofit EX with SX LED headlights

alexdrums

Well-known member
Messages
1,072
Reaction score
825
Points
113
Location
Phoenix
Thanks for the update! Hopefully the connectors will arrive soon.
 

TFamilyMan

New member
Messages
15
Reaction score
15
Points
3
Hi Machtig, I'm interested as well. I'd definitely pay you $100 to avoid the headache of splicing wires.

Great find on the conversion!
______________________________
 

machtig

Member
Messages
57
Reaction score
90
Points
18
Just got confirmation that the connectors have arrived at my local post office; I expect delivery tomorrow. That said I just realized I only ordered enough to build two sets of plug-and-play harnesses. But that is ok, as myself and another forum member are the only ones that have ordered in a pair of LED headlamps and I'd like to get mine (and his) installed and test them over a couple weeks to ensure there are no issues. By the time a new order of connectors arrives I'll be ready to build as many sets as necessary. (y)
 

TFamilyMan

New member
Messages
15
Reaction score
15
Points
3
Looks good so far. Your testing has convinced me 100%. To the point I just bought a pair of clean SX Led assemblies online. The wiring, wrap, and length is so professionally done. Plus you drafted out schematics. Are you an engineer by any chance?
 

Marcus T

New member
Messages
11
Reaction score
0
Points
1
Looks good so far. Your testing has convinced me 100%. To the point I just bought a pair of clean SX Led assemblies online. The wiring, wrap, and length is so professionally done. Plus you drafted out schematics. Are you an engineer by any chance?
Mind if I ask where you got them and how much you paid?
______________________________
 

machtig

Member
Messages
57
Reaction score
90
Points
18
I’m still testing. Everything but low beams works flawlessly; I’m having an issue with the low beams flickering when the car is running. They don’t flicker when off. It’s likely going to require a load resistor and maybe a relay. I have some resistors coming today. More to follow.
 
Looking to cover or replace the KIA emblems on your Telluride? Look no further than right here in our own forum store - where orders are shipped immediately!

Kwim

Active member
Messages
335
Reaction score
149
Points
43
I’m still testing. Everything but low beams works flawlessly; I’m having an issue with the low beams flickering when the car is running. They don’t flicker when off. It’s likely going to require a load resistor and maybe a relay. I have some resistors coming today. More to follow.
resistors should correct the flicker.
 
Top